// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{4,5})\s(.*)").unwrap();
let string = "35460 Bad Soden am Taunus
D-76275 Musterstadt
6275 Musterstadt 2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}