const regex = /\b(?:\d{4}[ -]?){3}(?=\d{4}\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:\\d{4}[ -]?){3}(?=\\d{4}\\b)', 'gm')
const str = `Hi here is my card number its visa 4242 4242 4242 4242
Hi here is my card number its visa 4242424242424242
Hi here is my card number its visa 4242-4242-4242-4242`;
const subst = `**** **** **** `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);