#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\strig:[01]\s.*"
Local $sString = "id:61Xxx9X3c-X095-Xb92-82fd-54bXX2XXc trig:3 date:1612330983 lat:XX.75XX1909XXX3XX long:X.XXX9XXXX5XXXXX dev:61Xxx9X3c-X095-Xb92-82fd-54bXX2XXc devAlias=-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")