# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(?s).*examples?:$"
test_str = (" /**\n"
" * Alias for {@link #toWithFixedName(String, String...)}.\n"
" *\n"
" * @param name The optional name of the TO receiver(s) of the email. If multiples addresses are provided, all addresses will be in\n"
" * this same name. Examples:\n"
" * @param oneOrMoreAddresses Single RFC2822 address or delimited list of RFC2822 addresses of TO receiver(s). Any names included are ignored if a\n"
" * name was provided. Examples:\n"
" * <ul>\n"
" * <li>lolly.pop@pretzelfun.com</li>\n"
" * <li>Lolly Pop<lolly.pop@pretzelfun.com></li>\n"
" * <li>a1@b1.c1,a2@b2.c2,a3@b3.c3</li>\n"
" * <li>a1@b1.c1;a2@b2.c2;a3@b3.c3</li>\n"
" * </ul>\n"
" */")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.