# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(1\s?)?((\([0-9]{3}\))|[0-9]{3})[\s\-]?[\0-9]{3}[\s\-]?[0-9]{4}$//gm;t' <<< "872-456-4532
(872) 456-4532
8724564532
1 872-456-4532
1 (872) 456-4532"