#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?<FULL>^(?<PATH>(?:\/|\.|\.\.){0,2})(?<CAPTURE1>\/[^\/\s]+)?(?<CAPTURE2>\/[^\/\s]+)?(?<CAPTURE3>\/[^\/\s]+)?(?<CAPTURE4>\/[^\/\s]+)?(?<CAPTURE5>\/[^\/\s]+)?(?<CAPTURE6>\/[^\/\s]+)?(?<FILENAME>\/[^\/\s]+)$)"
Local $sString = "./src/index.js" & @CRLF & _
"" & @CRLF & _
"./src/index.js#Soda" & @CRLF & _
"" & @CRLF & _
"./src/index.js?soda=fries" & @CRLF & _
"./src/index.js#soda?fries=hamburger" & @CRLF & _
"./src/index.js#soda?fries=hamburger&bag+o=chips" & @CRLF & _
"http://www.google.com/blugh/hello" & @CRLF & _
"https://www.google.com:8080/src/ui/template-management/create-template/versioning/version.js" & @CRLF & _
"http://localhost:8080/blugh/hello" & @CRLF & _
"../MyPath" & @CRLF & _
"This here is a normal sentence, though!" & @CRLF & _
"./src/ui/{FILE}.js[x]?" & @CRLF & _
"./src/ui/login.js" & @CRLF & _
"./src/ui/logout.js" & @CRLF & _
"" & @CRLF & _
"./src/ui/{FILE}/{FILE}.js[x]?" & @CRLF & _
"./src/ui/ad-hoc-messages/ad-hoc-messages.js" & @CRLF & _
"./src/ui/editor/editor.jsx" & @CRLF & _
"./src/ui/select-interaction/select-interaction.jsx" & @CRLF & _
"./src/ui/template-management/template-management.js" & @CRLF & _
"" & @CRLF & _
"./src/ui/{DIR}/{FILE}/{FILE}.js[x]?" & @CRLF & _
"./src/ui/ad-hoc-messages/send-ad-hoc-message/send-ad-hoc-message.js" & @CRLF & _
"./src/ui/admin-console/Department-management/Department-management.js" & @CRLF & _
"./src/ui/admin-console/tag-management/tag-management.js" & @CRLF & _
"./src/ui/template-management/create-template/create-template.js" & @CRLF & _
"./src/ui/template-management/create-template/versioning/version.js" & @CRLF & _
"" & @CRLF & _
"./src/ui/{DIR}/{FILE}.js[x]?" & @CRLF & _
"./src/ui/shared/select-template-to-send.js" & @CRLF & _
" " & @CRLF & _
"/select-interaction" & @CRLF & _
"/template-management" & @CRLF & _
"/template-management/create-template" & @CRLF & _
"/template-management/edit-template" & @CRLF & _
"/ad-hoc-messages" & @CRLF & _
"/ad-hoc-messages/send-ad-hoc-mail" & @CRLF & _
"/admin-console/category-management" & @CRLF & _
"/admin-console/tag-management" & @CRLF & _
"/Logout"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")