import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<FULL>^(?<PATH>(?:\\/|\\.|\\.\\.){0,2})(?<CAPTURE1>\\/[^\\/\\s]+)?(?<CAPTURE2>\\/[^\\/\\s]+)?(?<CAPTURE3>\\/[^\\/\\s]+)?(?<CAPTURE4>\\/[^\\/\\s]+)?(?<CAPTURE5>\\/[^\\/\\s]+)?(?<CAPTURE6>\\/[^\\/\\s]+)?(?<FILENAME>\\/[^\\/\\s]+)$)";
final String string = "./src/index.js\n\n"
+ "./src/index.js#Soda\n\n"
+ "./src/index.js?soda=fries\n"
+ "./src/index.js#soda?fries=hamburger\n"
+ "./src/index.js#soda?fries=hamburger&bag+o=chips\n"
+ "http://www.google.com/blugh/hello\n"
+ "https://www.google.com:8080/src/ui/template-management/create-template/versioning/version.js\n"
+ "http://localhost:8080/blugh/hello\n"
+ "../MyPath\n"
+ "This here is a normal sentence, though!\n"
+ "./src/ui/{FILE}.js[x]?\n"
+ "./src/ui/login.js\n"
+ "./src/ui/logout.js\n\n"
+ "./src/ui/{FILE}/{FILE}.js[x]?\n"
+ "./src/ui/ad-hoc-messages/ad-hoc-messages.js\n"
+ "./src/ui/editor/editor.jsx\n"
+ "./src/ui/select-interaction/select-interaction.jsx\n"
+ "./src/ui/template-management/template-management.js\n\n"
+ "./src/ui/{DIR}/{FILE}/{FILE}.js[x]?\n"
+ "./src/ui/ad-hoc-messages/send-ad-hoc-message/send-ad-hoc-message.js\n"
+ "./src/ui/admin-console/Department-management/Department-management.js\n"
+ "./src/ui/admin-console/tag-management/tag-management.js\n"
+ "./src/ui/template-management/create-template/create-template.js\n"
+ "./src/ui/template-management/create-template/versioning/version.js\n\n"
+ "./src/ui/{DIR}/{FILE}.js[x]?\n"
+ "./src/ui/shared/select-template-to-send.js\n"
+ " \n"
+ "/select-interaction\n"
+ "/template-management\n"
+ "/template-management/create-template\n"
+ "/template-management/edit-template\n"
+ "/ad-hoc-messages\n"
+ "/ad-hoc-messages/send-ad-hoc-mail\n"
+ "/admin-console/category-management\n"
+ "/admin-console/tag-management\n"
+ "/Logout";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}