use strict;
my $str = ' <div class="col-sm-8"><p>TLX is a Flat-Face twist lock coupling for the toughest applications in the construction and demolition segment. This super-duty quick connect coupling is designed to work with the highest surge flows and the toughest pressure impulses. TLX is made from high alloy steels with Zinc-Nickel surface treatment for a long life in the harshest conditions. The Series is available in sizes from ½” to 1 ½” to cover most applications.</p><br /><p>- The couplings and nipples are also available in 4 other sizes: ¾” (Series 607) 1” (Series 707) 1 ¼” (Series 807) and 1 ½ ” (Series 907) https://www.cejn.com/globalassets/documents/brochures/tlx-en.pdf</p></div>
<div class="col-sm-4">
<img src="/globalassets/product/cejn/series-507/group/series-507-tlx-group-cejn.jpg?w=275" rel="lightbox" alt="Series 507 - ½”" class="cboxElement" />
</div>
';
my $regex = qr/(https?:\/\/[-|\w\.|\/]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}