$re = '/(https?:\/\/[-|\w\.|\/]+)/';
$str = ' <div class="col-sm-8"><p>TLX is a Flat-Face twist lock coupling for the toughest applications in the construction and demolition segment. This super-duty quick connect coupling is designed to work with the highest surge flows and the toughest pressure impulses. TLX is made from high alloy steels with Zinc-Nickel surface treatment for a long life in the harshest conditions. The Series is available in sizes from ½” to 1 ½” to cover most applications.</p><br /><p>- The couplings and nipples are also available in 4 other sizes: ¾” (Series 607) 1” (Series 707) 1 ¼” (Series 807) and 1 ½ ” (Series 907) https://www.cejn.com/globalassets/documents/brochures/tlx-en.pdf</p></div>
<div class="col-sm-4">
<img src="/globalassets/product/cejn/series-507/group/series-507-tlx-group-cejn.jpg?w=275" rel="lightbox" alt="Series 507 - ½”" class="cboxElement" />
</div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);