using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(.*\n)*(.+?)(5)\[(.*)\](.\n)*(.*\n*)*";
string substitution = @"$4";
string input = @"SHIELD1[1SHIELD,2SHIELDCAP,3SHIELDPERCENT,]
ENERGY2[1POWER,2POWERCAP,3POWERPERCENT,]
STRUCTURE3[1STRUCTUREHP,2STRUCTUREHPCAP,3STRUCTUREHPPERCENT,]
ARMOR4[1ARMORHP,2ARMORHPCAP,3ARMORHPPERCENT,]
OTHER5[1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,]
SELECT THE MENU YOU WANT
[REPLACEFIRST](.*\n)*(.+?)(3)\[(.*)\](.\n)*(.*\n*)*[WITH]$4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}