// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?m)(.*\n)*(.+?)(5)\[(.*)\](.\n)*(.*\n*)*").unwrap();
let string = "SHIELD1[1SHIELD,2SHIELDCAP,3SHIELDPERCENT,]
ENERGY2[1POWER,2POWERCAP,3POWERPERCENT,]
STRUCTURE3[1STRUCTUREHP,2STRUCTUREHPCAP,3STRUCTUREHPPERCENT,]
ARMOR4[1ARMORHP,2ARMORHPCAP,3ARMORHPPERCENT,]
OTHER5[1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,]
SELECT THE MENU YOU WANT
[REPLACEFIRST](.*\\n)*(.+?)(3)\\[(.*)\\](.\\n)*(.*\\n*)*[WITH]$4";
let substitution = "$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}