package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(http:\/\/)?(\w*\.)*(cn)(\/.*)?$`)
var str = `cnn.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}