$re = '/^(?![0]\b)\d+\./m';
$str = 'any
10.0.0.1
0.0.0.255
22
telnet
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);