# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?\n(?=Paragraph)"
test_str = ("Text of variable length spread across several lines Serialization-type text separated by colons (eg ABC:DEF:GHI) A date\n\n"
"From: One line of text To: One or more lines Subject: One or more lines References: One or more lines\n\n"
"From: One line of text To: One \n"
"or \n"
"more \n"
"lines Subject: One or more lines References: One or more lines\n\n"
"From: One line of text To: One or more lines Subject: No references.\n\n"
"From: One line of text To: One or more lines Subject: One \n"
"or \n"
"more \n"
"lines \n"
"References: One or more lines\n\n"
"Paragraph 1 Title: A paragraph\n\n"
"Paragraph 2 Title: Another paragraph")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.