?repeats the group contents below at most once:
\^the literal ^ (9410 / 1368 / 5E16)
\{?optionally matches the literal { (12310 / 1738 / 7B16)
?optionally matches the literal (3210 / 408 / 2016)
\d*a Unicode decimal digit, repeated any number of times
?matches at most one character from the set below:
\+the literal + (4310 / 538 / 2B16)
-the literal - (4510 / 558 / 2D16)
\}?optionally matches the literal } (12510 / 1758 / 7D16)