import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]{1}[0-9]{8}[VvXx])|([1-9]{1}[0-9]{11})$";
final String string = "880053611V\n"
+ "198800503611\n"
+ "978561353V\n"
+ "199785601355\n"
+ "920600073V\n"
+ "199206000073";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}