#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:AGATC)+)(?!.*\1)"
Local $sString = "AGATCAGATCTTTTTTCTAATGTCTAGGATATATCAGATCAGATCAGATCAGATCAGATC" & @CRLF & _
"AGATCAGATCAGATCTTTTAGATCAGATCAGATCAGATCAGATCTTCTAATGTCTAGGATATATCAAGATCAGATC_AGATCAGATCAGATC_AGATCAGATCAGATCAGATC" & @CRLF & _
"AGATC_AGATCAGATC_AGATCAGATCAGATC_AGATC_AGATCAGATC" & @CRLF & _
"" & @CRLF & _
"re.search returns the first match in the last example." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")