import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:AGATC)+)(?!.*\\1)";
final String string = "AGATCAGATCTTTTTTCTAATGTCTAGGATATATCAGATCAGATCAGATCAGATCAGATC\n"
+ "AGATCAGATCAGATCTTTTAGATCAGATCAGATCAGATCAGATCTTCTAATGTCTAGGATATATCAAGATCAGATC_AGATCAGATCAGATC_AGATCAGATCAGATCAGATC\n"
+ "AGATC_AGATCAGATC_AGATCAGATCAGATC_AGATC_AGATCAGATC\n\n"
+ "re.search returns the first match in the last example.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}