$re = '/((?:AGATC)+)(?!.*\1)/m';
$str = 'AGATCAGATCTTTTTTCTAATGTCTAGGATATATCAGATCAGATCAGATCAGATCAGATC
AGATCAGATCAGATCTTTTAGATCAGATCAGATCAGATCAGATCTTCTAATGTCTAGGATATATCAAGATCAGATC_AGATCAGATCAGATC_AGATCAGATCAGATCAGATC
AGATC_AGATCAGATC_AGATCAGATCAGATC_AGATC_AGATCAGATC
re.search returns the first match in the last example.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);