re = /((?:AGATC)+)(?!.*\1)/m
str = 'AGATCAGATCTTTTTTCTAATGTCTAGGATATATCAGATCAGATCAGATCAGATCAGATC
AGATCAGATCAGATCTTTTAGATCAGATCAGATCAGATCAGATCTTCTAATGTCTAGGATATATCAAGATCAGATC_AGATCAGATCAGATC_AGATCAGATCAGATCAGATC
AGATC_AGATCAGATC_AGATCAGATCAGATC_AGATC_AGATCAGATC
re.search returns the first match in the last example.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end