$re = '/^((\<soafault:faultDescription\>)|(\"faultDescription\"\s+:\s+\"))(?<faultDescription>[^\"\<]+)/m';
$str = '"faultDescription" : "Backend system error has occurred.",
<soafault:faultDescription>SKU is not provided</soafault:faultDescription>
<soafault:faultDescription>SKU is not provided</soafault:faultDescription>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);