using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^a-zA-Z0-9_\-\/]){1}(monnaie)((?!<\/a>)(\W|$){1})";
string input = @"
L’usine de Pessac, en Gironde, produit chaque jour environ 5 millions de pièces de monnaie. Leur fabrication repose sur des processus industriels extrêmement exigeants et de nombreuses manipulations. Des contrôles qualité sont effectuées à toutes les étapes. Celles-ci nécessitent des savoir-faire parfois multi-séculaires, mais aussi des techniques de pointe.
La première étape est la découpe des flans à partir de lames de métal, au moyen de cisailles ou avec une machine. Les rondelles de métal sont alors préparées pour la frappe : elles sont recuites au four pour les rendre plus malléables.
La gravure intervient ensuite pour concevoir et réaliser coins et poinçons. Ces matrices de frappe sont des blocs d’acier qui fonctionnent par paire, de manière à graver simultanément l’avers et le revers d’une monnaie. Ainsi, les effigies, inscriptions et éléments décoratifs d'une monnaie sont gravés en creux et à l’envers sur le coin, en relief et à l’endroit sur le poinçon.
Comment procède le graveur ? A partir de son dessin, il réalise un modèle en bas relief avec de la pâte à modeler industrielle puis avec du plâtre. Pour concevoir le projet d’empreinte, le graveur fabrique lui-même ses outils et choisit les techniques, qui diffèrent selon les projets. Il fait appel aux techniques traditionnelles de la taille directe, mais aussi à l'optique de précision, à l’informatique et aux technologies mécaniques anciennes, comme la réduction et l’électro-érosion.
En quoi consiste la taille directe ? Tel un véritable artiste, le graveur se dispense de maquette, exécutant son oeuvre directement sur la matière définitive. Il procède généralement en creux, en réalisant son dessin d’origine à l’envers. Aucune erreur ne pouvant être corrigée, cette technique requiert une grande maîtrise. Des cylindres en alliage ultra-résistant sont ensuite gravés avant d’être usinés pour les adapter à la presse. Puis intervient la finition : le polisseur peut créer des couleurs ou pratiquer un « poli-miroir » qui donne aux pièces un aspect réfléchissant. Les coins subissent un traitement de surface pour accentuer leur rigidité et protéger la gravure.
Arrive enfin le monnayage : placé entre une paire de coins, le flan est frappé sur une machine de presse à froid, à une cadence de 850 coups / minute. La pression appliquée est de 30 tonnes. Une telle production de masse ne peut qu'être automatisée.
<a href="">monnaie</a> est plus encore !
Les pièces fabriquées à Pessac sont mono-colores ou bi-colores : par un procédé breveté, la <a class=""esk-seo-plu-link"" href=""https://abc.quaidesbalises.com/tags/monnaie-de-paris"">Monnaie de Paris</a> peut assembler une couronne et un coeur au moment même de la frappe de la pièce. A noter que certaines monnaies de collection bénéficient d’une finition spéciale appelée « brillant universel ». Frappées avec un outillage neuf, ces pièces ont un aspect brillant et sont dépourvues de traces de dégradation, puisqu'elle n'ont jamais circulé.
En fin de processus, les pièces de monnaie courantes sont mises en rouleaux puis en boîtes, et stockées avant d’être expédiées au client.
Que fait-on des pièces usées ou obsolètes ? Elles sont dénaturées : leur valeur faciale est détruite par écrasement. Redevenues des flans, elles sont alors fondues ou réutilisées pour une nouvelle fabrication.
<a class=""esk-seo-plu-link"" href=""https://abc.quaidesbalises.com/tags/-de-paris"">MONNAIE DE PARIS</a> : c'est top";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}