#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https):\/\/(www.|)upsie.com\/((?:\w+-)+warranty)\/(?:\w+)(.*)"
Local $sString = "https://upsie.com/smartphone-warranty/iphone?price_ceiling=999" & @CRLF & _
"https://upsie.com/smartwatch-warranty/all?brand=Samsung&category=Smartwatch&price_ceiling=299"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")