// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https):\/\/(www.|)upsie.com\/((?:\w+-)+warranty)\/(?:\w+)(.*)").unwrap();
let string = "https://upsie.com/smartphone-warranty/iphone?price_ceiling=999
https://upsie.com/smartwatch-warranty/all?brand=Samsung&category=Smartwatch&price_ceiling=299";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}