use strict;
my $str = '中文, 中文';
my $regex = qr/(?<=[\u4e00-\u9fa5]), *(?=[\u4e00-\u9fa5])/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";