$re = '/(?<![\.\d])(?:[0-9]\.|1\d?\d?\.|2[0-5]?[0-5]?\.){3}(?:[0-9]|1\d?\d?|2[0-5]?[0-5]?)(?![\.\d])/m';
$str = 'str1 = \'Hello my name is Ben and my IP address is 256.0.0.0\'
str2 = \'Hello my name is Folks and my IP address is 1.2.3.4.5\'
str3 = \'Hello all, ip addresses: 111.2.3., ip:0.0.0.0, 127.2.1.2\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);