package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)(running|stopped|starting)\.?$`)
var str = `Some text that will always end in either running, stopped, starting.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}