re = /^(?:подлесок:?+)(?:[ ]*+(?<TS1>[а-я]{1,4}|\d+)(?=[ ,+]|$))?+(?:[, +]*+(?<TS2>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS3>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS4>[а-я]{1,4}|(\d+))(?=[, +]|$))?+(?:[, +]*+(?<TS5>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:,?[ ]*+(?<DENSITY>средний|густой|редкий|ср\.густ|средней|редкой))?.*+$/mi
str = 'подлесок: Р КС ОЛК СР.ГУСТ
подлесок: Р КУЛ СРЕДНИЙ
подлесок: ИВК Р СРЕДНИЙ
подлесок: КУЛ ЛЩ СРЕДНИЙ
подлесок: Ч,Кл,Лщ средний
подлесок: Ч,Кл,Лщ густой
подлесок: ЛЩ ЛС КЛ средний
подлесок: РН СП густой
подлесок: СП РН Ч густой
подлесок: КЛ КС РЕДКИЙ
подлесок: Лщ редкий
подлесок: БРК КРЛ Р
подлесок ЛЩ+КРЛ+ИВК редкий
подлесок ЛЩ+КРЛ редкий'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end