import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"^(?:подлесок:?+)(?:[ ]*+(?<TS1>[а-я]{1,4}|\d+)(?=[ ,+]|$))?+(?:[, +]*+(?<TS2>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS3>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS4>[а-я]{1,4}|(\d+))(?=[, +]|$))?+(?:[, +]*+(?<TS5>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:,?[ ]*+(?<DENSITY>средний|густой|редкий|ср\.густ|средней|редкой))?.*+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
подлесок: Р КС ОЛК СР.ГУСТ
подлесок: Р КУЛ СРЕДНИЙ
подлесок: ИВК Р СРЕДНИЙ
подлесок: КУЛ ЛЩ СРЕДНИЙ
подлесок: Ч,Кл,Лщ средний
подлесок: Ч,Кл,Лщ густой
подлесок: ЛЩ ЛС КЛ средний
подлесок: РН СП густой
подлесок: СП РН Ч густой
подлесок: КЛ КС РЕДКИЙ
подлесок: Лщ редкий
подлесок: БРК КРЛ Р
подлесок ЛЩ+КРЛ+ИВК редкий
подлесок ЛЩ+КРЛ редкий
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)