const regex = /^([a-z0-9-_.]+\@[a-z0-9-.]+\.[a-z]{2,4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z0-9-_.]+\\@[a-z0-9-.]+\\.[a-z]{2,4})$', 'gm')
const str = `test@mail.ru
test-test@mail.ru
test.test@mail.ru
test@mm.mr.com
test.rf
test@fsd@ff.ro
testsfdsfsdf
@fdsf.rf
fsd@fsd.rf
fs_0-9.9d@f4-34.sd.rf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}