using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)S-2(.*)$";
string substitution = @"$0\n$1S-4$2";
string input = @"Some text SELLO S-2 BREAK &Logic,0
Some other text SELLO S-2_BREAKTWO &Logic,0
Wear EXT &SELO-344 S-2,0,30";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}