use strict;
my $str = 'Some text SELLO S-2 BREAK &Logic,0
Some other text SELLO S-2_BREAKTWO &Logic,0
Wear EXT &SELO-344 S-2,0,30';
my $regex = qr/^(.*)S-2(.*)$/mp;
my $subst = '$0\\n$1S-4$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";