# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*)S-2(.*)$"
test_str = ("Some text SELLO S-2 BREAK &Logic,0\n"
"Some other text SELLO S-2_BREAKTWO &Logic,0\n"
"Wear EXT &SELO-344 S-2,0,30")
subst = "$0\\n$1S-4$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.