# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^[ \t]*)Global([^\n\;\\/]*);?/$1public static$2;/gm;t' <<< "Global Base:TList=New TList; // База загруженных спрайтив. Чтобы не грузить одно и то же
//цвета ключевых пикселей, испульзуемых в поиске
Global PxAlpha = -GenRgb(0, 0, 0, 0)
Global PxRed = -GenRgb(0, 1, 0, 0) // 65536
Global PxBlack = -GenRgb(1, 0, 0, 0); // 16777216
Global => public static"