#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?=\b\d|\G)\d+?(?=(?:\d{3})+\b)"
Local $sString = "12345678"
Local $sSubst = "$0,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)