import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([a-zA-Z]:)|(\\\\{2}\\w+\\\\[\\w- ]+[$])|(\\\\{2}\\w+))(\\\\[\\w-. ]*)*(.xml|.XML)$";
final String string = "XX2 03-01-2017.xml";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}