$re = '/^(([a-zA-Z]:)|(\\\\{2}\w+\\\\[\w- ]+[$])|(\\\\{2}\w+))(\\\\[\w-. ]*)*(.xml|.XML)$/';
$str = 'XX2 03-01-2017.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);