re = /^(([a-zA-Z]:)|(\\{2}\w+\\[\w- ]+[$])|(\\{2}\w+))(\\[\w-. ]*)*(.xml|.XML)$/
str = 'XX2 03-01-2017.xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end