package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([a-zA-Z]:)|(\\{2}\w+\\[\w- ]+[$])|(\\{2}\w+))(\\[\w-. ]*)*(.xml|.XML)$`)
var str = `c:\path\\XX2 03-01-2017.xml
\\nas\user$\XX2 03-01-2017.xml
\\network_shared\.xml
\\a.XML`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}