#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^[^=:\r\n]+[=:]|\G(?!^))(?:b\d{1,2})?\K.*?(?=b\d{1,2}|$)"
Local $sString = "Accept-Language: en-EN" & @CRLF & _
"n1.legend=0,1,meta,text,Legend,b1,30 chars max" & @CRLF & _
"n1.legend=0,1,meta,text,Legend,b1,30 chars maxb12test" & @CRLF & _
"r1.label=Contain" & @CRLF & _
"" & @CRLF & _
" en-EN" & @CRLF & _
"0,1,meta,text,Legend,b1,30 chars max" & @CRLF & _
"0,1,meta,text,Legend,b1,30 chars maxb12test" & @CRLF & _
"Contain"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")