#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\S)Male-Cat(?!\S)"
Local $sString = "Male-Cat Male-Cat Male-Cat-Female" & @CRLF & _
"Male-Cat Male-Cat Male-Cat" & @CRLF & _
"" & @CRLF & _
"Male-Cat Female-Cat Male-Cat-Female Male-Cat'" & @CRLF & _
"Male-Cat-Female" & @CRLF & _
"Male-Cat"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")