const regex = new RegExp('(?<!\\S)Male-Cat(?!\\S)', 'g')
const str = `Male-Cat Male-Cat Male-Cat-Female
Male-Cat Male-Cat Male-Cat
Male-Cat Female-Cat Male-Cat-Female Male-Cat'
Male-Cat-Female
Male-Cat`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}