import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = ".*Voyage\\:\\\\xa0{1}\\s+([0-9]{4}[A-Z]{1}).*";
        final String string = " \\nSEASPAN LONCOMILLA\\n\\r\\n        Voyage:\\xa0 1396S\\r\\n        \\n\\n\\r\\n                    10-Apr\\r\\n                    ALGECIRAS\\r\\n                    \\n\\n\\r\\n                    01-May\\r\\n                    KRIBI\\r\\n                    \\n\\n'";
        
        final Pattern pattern = Pattern.compile(regex);
        final Matcher matcher = pattern.matcher(string);
        
        if (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}