const regex = new RegExp('.*Voyage\\:\\\\xa0{1}\\s+([0-9]{4}[A-Z]{1}).*', '')
const str = ` \\nSEASPAN LONCOMILLA\\n\\r\\n        Voyage:\\xa0 1396S\\r\\n        \\n\\n\\r\\n                    10-Apr\\r\\n                    ALGECIRAS\\r\\n                    \\n\\n\\r\\n                    01-May\\r\\n                    KRIBI\\r\\n                    \\n\\n'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}