package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^--START\h*\R\s*(.*?)\h*\R\s*--END$`)
var str = `--START
select * from table;
--END`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}