package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{2})\.(\d{2})-(\d{4})`)
var str = `01.10-2016`
var substitution = "$1/$2/$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}