use strict;
my $str = '01.10-2016';
my $regex = qr/(\d{2})\.(\d{2})-(\d{4})/mp;
my $subst = '$1/$2/$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";