import Foundation
let pattern = #"(\d{2})\.(\d{2})-(\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"01.10-2016"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/$2/$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)