using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d|\.)((\d\.\d|\d)(?!\d|\.\d)[^\d,;.]+?listening)";
string input = @"ielts 6. overall 6.5; reading 6; writing 6; speaking 6.6 listening 6. for other english language proficiency tests and scores approved for uq listening 6.6";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}