import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)?apps\\.apple\\.com(\\/[a-zA-Z]{2})?\\/(app|developer)\\/.+";
final String string = "https://apps.apple.com/us/app/poppy-playtime-chapter-1/id1610947489\n"
+ "http://apps.apple.com/SA/app/poppy-playtime-chapter-1/id1610947489\n"
+ "https://apps.apple.com/app/id1610947489\n"
+ "apps.apple.com/app/id1610947489\n"
+ "https://apps.apple.com/us/developer/mobgames/id1608636552\n"
+ "https://apps.apple.com/us/devEloper/mobgames/id1608636552";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}